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SINUMERIK
SinuTrain for SINUMERIK Operate
Training and Programming
Compact User Manual

Preface
Welcome to the SinuTrain for SINUMERIK Operate - Training and programming at
the PC.

The training software SinuTrain for SINUMERIK Operate teaches you how to operate
and program the 840D sl control system / 828D.

SinuTrain for SINUMERIK Operate - Training and programming

This documentation supports you step-by-step for the following tasks:

● Installing the training software from DVD

● Transferring the license

● Starting the program

● Selecting the machine tool

● Starting simulation

What groups does SinuTrain for SINUMERIK Operate address?

SinuTrain for SINUMERIK Operate is designed for basic and further training of the
following target groups:

● First time users, users changing over from a different system

● Training managers, trainers

● Sales personnel for customer presentations

● CNC programmer for work preparation
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Information

Information on the following topics is available at the link
http://www.siemens.com/motioncontrol/docu:

● Ordering documentation
Here you can find an up-to-date overview of publications.

● Downloading documentation
Links to more information for downloading files from Service & Support.

● (online) research in the documentation
Information on DOConCD and direct access to the publications in DOConWEB.

● Compile customized documentation
My Documentation Manager provides you with a range of features for generating
your own machine documentation.
See also http://www.siemens.com/mdm

● Training and FAQs
Information on our range of training courses and FAQs (frequently asked
questions) is available via the page navigation.

Legal basics

This software (SinuTrain™) is used to generate and simulate NC programs on a PC
based on the DIN 66025 programming language as well as the ShopMill, ShopTurn
and language commands, type Sinumerik™ 828D and 840D sl. The programs
generated with the software must only be used on machine tools for production if the
software (SinuTrain/JobShop), on which the generated program should run, has
been adapted to Sinumerik.

This adaptation must be professionally performed by authorized personnel, e.g. by
Siemens, by machine tool OEMs or by dealers; when carrying out any adaptation
work, the specifications of Siemens and the machine tool OEM must always be
carefully observed. Otherwise, the machine tool could malfunction.

Otherwise, for customers in Germany, the "Allgemeinen Bedingungen zur
Überlassung von Software für Automatisierungs- und Antriebstechnik an
Lizenznehmer mit Sitz in Deutschland" applies for the software and for customers
outside Germany "General License Conditions for Software Products for Automation
and Drives for Customers with a Seat or Registered Office outside of Germany".

http://www.siemens.com/motioncontrol/docu
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Technical Support

If you have any technical questions, please contact our hotline:
Europe / Africa

Phone +49 (0)911 895 7222
Fax +49 (0)911 895 7223
0.14 €/min from the German landline; cell phone charges may vary.
Internet https://www.siemens.com/automation/support-request

Americas
Phone +1 423 262 2522
Fax +1 423 262 2200
E-mail mailto:techsupport.sea@siemens.com

Asia / Pacific
Phone +86 1064 757 575
Fax +86 1064 747 474
E-mail mailto:support.asia.automation@siemens.com

Note
Country-specific telephone numbers for technical support are provided under the
following Internet address:
https://www.automation.siemens.com/partner

Questions about the manual

If you have any queries (suggestions, corrections) in relation to this documentation,
please fax or e-mail us:
Fax +49 9131- 98 2176
E-mail mailto:docu.motioncontrol@siemens.com

Internet address

http://www.cnc4you.siemens.com

https://www.siemens.com/automation/support-request
mailto:techsupport.sea@siemens.com
mailto:support.asia.automation@siemens.com
https://www.automation.siemens.com/partner
mailto:docu.motioncontrol@siemens.com
http://www.cnc4you.siemens.com/
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1 Overview
The SinuTrain for SINUMERIK Operate training software (called SinuTrain in the
following) simulates a SINUMERIK 840D sl with the SINUMERIK Operate user
interface on your PC.

Note
License
You require a license to start a machine using the full functional scope.

True to original representation and behavior

As a result of the true to original representation of the operating panel front, machine
control panel and user interface, SinuTrain facilitates real operation.

● SinuTrain includes a machine control panel with specific functions of a real
control panel (e.g. CYCLE START, operating mode etc.).

● SinuTrain includes an operator panel, with which all of the specific functions of a
real operator panel can be used (hotkey etc.).

● The user interface corresponds to the original interface of SINUMERIK Operate.

● The simulation behaves in precisely the same way as a real control.

Saving and printing NC programs

SinuTrain offers the option of saving the NC programs that you have created (G code
and machining step programs).

You also have the option of printing out a program which is open in the user interface
of SINUMERIK Operate.
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2 Licensing using the Automation License
Manager

You require a valid license key to start a machine with the full functional scope in
SinuTrain. It is an integral part of SinuTrain for SINUMERIK Operate, and is supplied
on a USB stick.

A license is not required to use SinuTrain.

All operating areas and functions can be operated.

License

Additional functions are available with a license (Page 55).

Note
Information on the license
More detailed information on licenses is available in the readme.

Transferring the license using the Automation License Manager

Precondition: USB stick with the license to be transferred.

1. Start the Automation License Manager via the icon or from the Start menu.
The Automation License Manager opens.

2. Insert the USB stick.
A "Removable Disk" appears below "Own Computer".

3. Select the entry "Removable Disk" on the lefthand side.
On the right-hand side you can see the available licenses on the USB stick.

4. Transfer the license by dragging and dropping it onto the local hard disk.
- OR -
Select “Transfer" in the shortcut menu of the license.

5. In the window that opens, select where the license should be transferred to
(target).
After the license has been transferred, this is shown on the target drive.
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3 License model
The usage and scope of functions provided by the various template machines
depends on the availability of a license.

DEMO machines

● You do not require any license for the "DEMO turning machine" template
machines (1-channel, 3-axis machine with main spindle and driven tool spindle)
and "DEMO milling machine" (1-channel, 3-axis machine).

● DEMO machines are preconfigured machines that cannot be changed.

● You can start and operate the machines.

● You can, for example, transfer workpieces and part programs to the machine for
program simulation and customization, and then from the machine for further use
on CNCs.

● The following functions are not available:
– Collision avoidance
– Measuring cycles
– CAD reader

Template machines / imported machines / machines created from the start-up
archive

● You can start and operate all machines. This makes it possible for you to try all
SINUMERIK functions.

● All machines have the full functional scope of SINUMERIK Operate.

● License
– Without license

The transfer of workpieces and part programs to or from the machine is not
possible.

– With license
The transfer of workpieces and part programs to or from the machine is
possible.

Note
Importing a license subsequently
If you import a license when the machine has already been started, this causes a
restart.
Only then is it possible to use the machine without restrictions.
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Exporting and importing machines / printing part programs

You generally require a license for the "Import" and "Export" functions of machines as
well as for the printing of part programs.
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4 SinuTrain for SINUMERIK Operate

4.1 Installing / uninstalling SinuTrain

4.1.1 System requirements
Hardware

Processor: 1.5 GHz (singlecore)

RAM: 2 GB

Hard disk:

● 3.3 GB for complete installation with all languages

● 1.2 GB for minimal installation (language English)

DVD drive: For installation using DVD data storage medium

Graphic card: Minimum resolution, 640x480 pixels

USB interface

Mouse, keyboard

Operating systems

● Windows 7 (32-bit and 64-bit, Starter, Web Edition and Embedded are not
supported)

● Windows 8.1

Software

Adobe Acrobat Reader®

4.1.2 Installing SinuTrain

Precondition

You require a license key to start and work with machines that have been created.
This key must be transferred to the PC before starting a machine for the first time.
When installing SinuTrain, an additional program is installed for this purpose – the
Automation License Manager. The license key is transferred to the PC using the
Automation License Manager.

The SinuTrain for SINUMERIK Operate software product comprises various software
components that in some cases have their own setup (e.g. Automation License
Manager).
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General setup

In a general setup, initially the Automation License Manager and SinuTrain are
installed. The CAD reader is then optionally installed.

Procedure

1. Double-click the "setup.exe" in the root directory of the DVD.
Under Windows 7, when the user account control is activated, after double-
clicking the "setup.exe", a system prompt appears. With this prompt, you agree
that setup can make changes to your system (this prompt comes from Windows
and is not a component created by Siemens). Confirm this dialog and continue
with the installation.

2. Select the setup language and click the "Next >" button.

3. Read the notes on the installation and usage of the program and click the "Next
>" button.

4. Click the "Readme" button to read the readme text with the product notes, then
close the readme file and click the "Next >" button.

5. Read the license agreement and then activate the checkbox to accept the
licensing agreement and the safety instructions and click the "Next >" button.

6. Select the languages in which you wish to install SinuTrain for SINUMERIK
Operate .
The selected languages are available in SinuTrain as well as SINUMERIK
Operate.

7. In the "Programs" window, activate the required checkbox and click the "Next>"
button.
If you want to change the installation path of the individual products, select the
specific product, click the "Browse" button and select the required folder.

Note
Before installing SinuTrain, under certain circumstances, system updates are
automatically installed, which may make it necessary to restart the computer.
Setup is automatically continued after the PC restarts.

The installation of SinuTrain and Automation License Manager then starts.
You receive an appropriate message after completing the installation of
SinuTrain.

8. Click the "Exit" button.
SinuTrain and the Automation License Manager are ready.
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Note
User account control for Windows 7
When querying the user account control, if "unknown" is specified as the supplier and
the upper part of the dialog is not blue-green, but orange-yellow, then respond with
No and contact the hotline.
All Siemens products released for Windows 7 have a certificate, where Siemens AG
is always specified when querying the supplier.

Note
Click the "Cancel" button to exit the installation.

Note
We recommend that the installation is not started from a network drive. This is
because problems can be encountered as a result of possible necessary system
updates.

4.1.3 Uninstalling SinuTrain

Procedure

1. In the Windows menu, select Start > Settings > Control Panel.

2. Double-click "Programs and functions" in the list of the Control Panel (Windows
7).
The "Change or remove programs" button is active.

3. In the software list, select "SinuTrain for SINUMERIK Operate 4.7" and click the
"Remove" button.
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4.2 Operating SinuTrain

4.2.1 This is how SinuTrain functions

Precondition

SinuTrain for SINUMERIK Operate has been installed.

General sequence

● Selecting a language
Select the required language for SinuTrain and SINUMERIK Operate at the first
start.

● Starting SinuTrain
After confirming the Terms of Use, SinuTrain opens with the machine overview.

● Creating a machine
Create a machine in the machine overview.
First select a machine of the required type using templates.
Then specify the name and brief description of the machine, if required, select
your own machine image for the machine overview and specify the resolution and
language of the machine simulation in the SINUMERIK Operate user interface.

● Starting a machine
The machine simulation opens with operator panel and SINUMERIK Operate
user interface, machine control panel with feedrate and spindle override and CNC
keyboard.

● Simulating a machine
You can now operate the simulated machine just like a real machine and
generate programs, for example.
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4.2.2 Machine overview
In the machine overview, you create machines and parameterize and manage the
machine configurations with which you train.

① SinuTrain menu
② Machine overview with all created machines
③ Functions page with options for the creation of machine configurations
④ Created machine configuration with machine name and description
⑤ Selected machine configuration

See also

Menu commands (Page 83)

Context menu (Page 86)

Overview (Page 66)

Creating a machine from a template (Page 67)

Copying and configuring a machine (Page 68)

Importing a machine (Page 69)

Creating a machine from the start-up archive (Page 71)
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4.2.3 Screen layout of the machine simulation

User interface of SinuTrain

① SinuTrain menu
② SINUMERIK Operate user interface
③ Operator controls of an operator panel
④ Machine control panel with feedrate and spindle override

See also

Menu commands (Page 83)
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4.2.4 Installing languages

4.2.4.1 Installing additional languages for Sinutrain
Select the required language when installing SinuTrain for SINUMERIK Operate. The
user interface of SINUMERIK Operate is also installed with the selected language.

The following standard languages are available for selection during the installation:
English, German, French, Italian, Spanish and simplified Chinese.

Subsequent installation of SinuTrain languages

If you have not selected one of the standard languages during the installation of
SinuTrain, you can install the required language subsequently by performing the
setup (repair installation) again. SINUMERIK Operate is then also available in the
language.

4.2.4.2 Installing additional languages for SINUMERIK Operate
You can install further languages for the SINUMERIK Operate user interface.

installing additional languages

Additional language packages are offered for download at the following Internet
address:

http://www.cnc4you.siemens.com (http://www.cnc4you.siemens.com)

Procedure

1. Select the Tools > Install additional HMI languages... menu command.
The "Install additional HMI languages" window opens.

2. Click the "..." button and navigate in the "Open" dialog to the storage location of
the language packages.

3. Select the required language file (*.slf) and click the "Open" button.
You return to the "Install additional HMI languages" window.
The storage path has been entered. The selected language is displayed and
marked with a flag icon. In addition, the version of the SINUMERIK Operate
language package and the control type are displayed.

4. Click the "Install" button.
A progress bar shows the installation process.
You receive a message after successful installation.

http://www.cnc4you.siemens.com/
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5. Click the "OK" button to complete the installation.

Note
After the message regarding successful installation, you have the option of disabling
future installations of language packages. To do this, activate the "Do not display this
note again" checkbox.
Select the Tools > Options menu command and activate the "Report completion of
the language installation" checkbox in the "Options" window in order to switch the
message on again for future installations.

4.2.5 Changing the SinuTrain language
You have the option of changing over the language (German, English, French,
Spanish, Italian, Chinese simplified) of the SinuTrain user interface.

All languages installed during the setup or those subsequently installed can be
selected.

Note
Subsequent installation of SinuTrain languages
If you have not selected one of the standard languages during the installation of
SinuTrain, you can install the required language subsequently by performing the
setup (repair installation) again.

Procedure

1. Select the Tools > Options menu command.

2. Select the required language in the "Language of the SinuTrain user interface"
drop-down list and click "OK".

Note
Changing the language of SINUMERIK Operate
In SINUMERIK Operate you can change the language of the SINUMERIK Operate
user interface using the key combination <CTRL + L> or in the "Commissioning"
operating area, using the "Change language" softkey.

See also

Installing additional languages for SINUMERIK Operate (Page 63)
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4.3 Working with SinuTrain

4.3.1 Starting and exiting SinuTrain

Starting SinuTrain

1. Select the Programs > SinuTrain for SINUMERIK Operate  > SinuTrain menu
command.
- OR -
Double-click the SinuTrain icon on your desktop.

At the first start, the dialog for the selection of the language for the SinuTrain user
interface and SINUMERIK Operate opens.

2. Select the required language and click "Next".
Note: The languages are available that you selected during the installation of
SinuTrain.
The Terms of Use for SinuTrain for SINUMERIK Operate open.

3. Click "OK" to start the program.
The machine overview opens.
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Note
You can deactivate the Terms of Use for future program starts. To do this, activate
the "Do not display this note again" checkbox.
Select the Extras > Options menu command and activate the "Display Terms of Use
at program start" checkbox in the "Options" window in order to switch the message
on again for future starts.

Exiting SinuTrain

● Select the File > Exit menu command.
SinuTrain closes.

See also

Installing additional languages for Sinutrain (Page 63)

4.3.2 Creating a machine

4.3.2.1 Overview
You have the following options when creating a machine:

● Creating a machine from a template (Page 67)
The standard configurations supplied for lathes and milling machines form the
basis.

● Copying and configuring a machine (Page 68)
The basis is a machine configuration that you created, which already exists in the
machine overview.

● Importing a machine (Page 69)
The basis is an exported machine configuration, which you import and modify.

● Creating a machine from the start-up archive (Page 71)
The basis is a start-up archive (*.arc).
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4.3.2.2 Creating a machine from a template

Requirement

SinuTrain has been started and the machine overview is open.

Creating a machine from a template

1. Click the "Use template" option in the "Create new machine" functions page.

- OR -
Select the File > New > From a template... menu command.
The "Create new machine - Use template" dialog opens.

Note
Various template machines are available depending on the available SINUMERIK
version.

2. Open the "Machine type" drop-down list and select the required template.
You can select the required CNC software (e.g. 4.7) in the data tree that opens
for each system (e.g. 840D sl).
After selection, the system and software version of the selected machine is
displayed in the "Created with CNC SW" field.

3. In the "Machine name" entry field, enter a name for the machine (e.g. My
machine).

4. If required, enter a short description in the "Description" entry field.
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5. Select the resolution for the machine user interface (e.g. 1024 x 768).

6. Select the language for the machine user interface (e.g. English).

7. If you want to use your own machine image for the machine display, click the "..."
button next to the "Import image" field, navigate in the "Open" dialog to the
storage location of the graphic (*.png,*.jpg,*.bmp) and click "OK".
You return to the "Create new machine - Use template" window. The storage path
is displayed.

8. Click the "Create" button.

Note
If a machine with this name already exists, a corresponding message is
displayed. Click "OK" and enter a new machine name.

The machine configuration for the SINUMERIK 840D sl is inserted in the
overview.

4.3.2.3 Copying and configuring a machine

Requirement

● SinuTrain has been started and the machine overview is open.

● Machines have been created.
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Creating a new machine configuration

1. In the machine overview, select the machine configuration that you want to copy
and use for another machine.

2. Select the File > Copy and Paste menu command.
- OR -
Right-click and select “Copy and Paste" from the shortcut menu.
The machine is added to the machine overview and identified by a number in the
machine name.

3. Then select the Machine > Settings... menu command for the copied machine.
- OR -
Right-click and select "Settings..." from the shortcut menu.
The "Edit machine" dialog opens.

4. Enter the desired changes (e.g. machine name, resolution, language, machine
image) and click "Save and close".

See also

Changing machine settings (Page 74)

4.3.2.4 Importing a machine

Requirements

● You have a license.

● SinuTrain has been started and the machine overview is open.

● You have exported machine configurations as backup or as starting point for
subsequent machine configurations.

Note
Different SINUMERIK CNC system software versions
The SINUMERIK CNC system software version of the file to be imported is available
with SinuTrain for SINUMERIK Operate . With different versions, manual changes
must be made subsequently in accordance with the NC upgrade instructions.
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Importing a machine

1. Click the "Import machine" option in the "Create new machine" functions page.

- OR -
Select the File > Import... menu command.
The "Create new machine - Import machine" window opens.

2. Click the "..." button next to the "Selected file" field and navigate in the "Open"
dialog to the storage location of the exported configurations.

3. Select the required machine configuration file (*.set) and click the "Open" button.
You return to the "Create new machine - Import" window.
– The storage path is shown in the "Selected file" field.
– The "Created with CNC SW" field shows the SINUMERIK CNC software

version and the system (e.g. 840D sl) with which the machine configuration
has been created.

4. Change the required settings as needed (e.g. machine name, description, etc.)
and import your own machine image if applicable.

Note
Note that machines with identical names are not permitted in the machine
overview.
Always change the machine name in the "Create new machine - Import" window
even if you do not want to change the type of machine.

5. If you want to use the selected archive as a template for other machines in the
future, check the checkbox "Create as template".
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6. Click the button "Import machine".

Note
Warning notices and messages
If problems occur when importing the machine configuration, a window opens
with the appropriate messages. Elements (e.g. cycles) that have not been
imported error-free are listed with the appropriate descriptions.
Click "OK" to close the window.

You return to the machine overview and the machine is created.

4.3.2.5 Creating a machine from the start-up archive
Note the following conditions when creating machines from start-up archives.

● SINUMERIK CNC system software version and SinuTrain for SINUMERIK
Operateversion must match, otherwise it may not be possible to adapt the
machine configuration.

Note
Manual adaptation of the machine configuration
If an adaptation is not possible, manual changes must be made subsequently in
accordance with the NC upgrade instructions.

● If data is contained which is not suitable or not required for use in SinuTrain (e.g.
for the PLC or drives), the machine configuration is adapted.

Note
An overview of all adapted machine data can be found in the online help for the
CNC software. Select the menu command Help > Help for SINUMERIK CNC SW
> and the corresponding software version.

● The setup archive must contain all NC data.

● Start-up archives from powerline systems and HMI-Advanced/Embedded cannot
be used.

Requirement

● You have a license.

● SinuTrain has been started and the machine overview is open.
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Creating a machine from a setup archive

1. Click the "Read setup archive" option in the "Create new machine" functions
page.

- OR -
Select the File > New > From a setup archive... menu command.
The "Create new machine - Read setup archive" dialog opens.

2. Click the "..." button next to the "Selected file" field and navigate in the "Open"
dialog to the storage location of the required archive file (*.arc), select the file and
click "Open".
A message informs you that the archive is being checked.
You return to the dialog and the selected file is displayed with the directory path.
The control type and software version of SINUMERIK Operate are also displayed.

Note
Notice messages
After the setup archive is imported, you will get a window with informational
messages, which point out possible errors and problems.
You have the capability of copying the figures entered in the "Description" column
via the button and to then send them to the hotline (Page 48) for analysis.

3. Enter the required specifications for the machine configuration (name and
description) in the corresponding entry fields, if required, import your own
machine image and select the resolution (e.g. 1024 x 768) and language (e.g.
English) of the machine user interface.
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4. Click the "Read setup archive" button.

Note
If a machine with this name already exists, a corresponding message is
displayed. Click "OK" and enter a new machine name.

The created machine configuration is inserted in the overview and shows the date
of creation.
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4.3.3 Changing machine settings
You can change the following settings for a machine:

● General
– Machine name
– Description

● Language
Machine interface language (German, English, French, Spanish, Italian, simplified
Chinese). Only the languages selected during installation are available for
selection.
If you have subsequently installed additional languages, these are also available
for selection.

● Resolution
Resolution of the machine interface
– 640x480
– 800x600
– 1024x768
– 1280x1024

● Importing an image
Your own machine images can be stored in the following formats:
– PNG
– JPG
– BMP

Procedure

1. In the machine overview, select the machine for which you want to change the
settings.

2. Select the Machine > Settings... menu command.
- OR -
Right-click and select "Settings..." from the context menu.
The "Edit machine" dialog opens.

3. Enter the required changes and click "Save and close".
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4.3.4 Exporting a machine configuration
You have the option of exporting machines that you have configured in order to back
them up. The exported machine configurations are available as a starting point for
later machine configurations or as a back-up copy. To do this, import the saved
machine configuration file.

Exported machine configurations allow you to exchange these between two
computers or to subsequently import them into more recent SinuTrain versions.

Requirement

You have a license.

Procedure

1. In the machine overview, select the machine configuration that you want to
export.

2. Select the File -> Export menu command.
- OR -
Right-click and select "Export..." from the context menu.
The "Save as" dialog opens.

3. Navigate to the desired storage location, if required, change the file name and
click "Save".
You receive a message after a successful export.

4. Click "OK" to finish the export.

Note
You can deactivate the message for the successful export. To do this, activate the
"Do not display this note again" checkbox.
Select the Tools > Options menu command and activate the "Report completion of
the machine export" checkbox in the "Options" window in order to switch the
message on again for future exports.
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4.3.5 Deleting a machine
If you do not require a machine configuration any longer, delete it from the machine
overview.

Procedure

1. Select the machine that you want to remove from the Machine configuration list.

2. Select the File > Delete menu command.
- OR -
Right-click and select "Delete" from the context menu.

3. Confirm the message regarding the possible loss of data with "OK" and click in
the subsequent prompt dialog box the "Yes" button to delete the machine.

Note
SinuTrain machine with user data
When deleting a machine, all user data (e.g. NC programs, work offsets, etc.) are
lost. The data associated with a deleted machine cannot be restored.

Note
You have the option of disabling the message regarding data loss for future delete
operations. To do this, activate the "Do not display this note again" checkbox.
Select the Tools > Options menu command and activate the "Inform of possible data
loss before deleting" checkbox in the "Options" window in order to switch the
message on again for future deletions.

4.3.6 Printing-out a program
You can print out the contents of text files (e.g. NC programs) using a printer
configured on the PC (local printer, network printer) directly via SinuTrain from the
SINUMERIK Operate user interface.

You can print G code programs as well as ShopMill and ShopTurn machining step
programs with G code.
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Defining the layout

In the "Print settings" window, you specify the layout for the printing, define the scope
of the NC program that is to be printed and configure the display of the program.
Settings Effect
Margins
(mm) Left: Right:

Here you define the margins of the printout.
Defines the distance between the top,
bottom, right and left margin and the
respective edge of the lines in mm.

Top: Bottom:

Print
area

Everything

Here you define the scope of the program
printout.
Defines that the complete NC program is
printed.

Lines
from: to:

Defines the lines of the NC program that
are to be printed.

Selected range Defines that only the part of the NC
program marked in the editor is to be
printed.

Print programs as text Defines that sequence programs
(ShopMill/ShopTurn) are printed out as G
code.

Print programs with graphical
illustrations

Defines that machining step programs
(ShopMill/ShopTurn) will be printed in the
same way as they appear in the editor.

Print programs with
input screen

Defines that the parameter screens for the
machining steps are also printed out.

Print closed blocks Defines that when using program blocks,
the program sets in the blocks are also
printed.

Requirement

You require a license to print from the SINUMERIK Operate user interface.
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Procedure
1. In the archive folder of the program manager, select the program

that you wish to print out.

2. Place the cursor on the program and press the "Open" softkey.
The program opens in the editor.

3. Select the File > Print settings... menu command.
4. Enter the distances for the margins in the "Print settings" window,

define the print range and the representation type of the program
and click the "OK" button to confirm your entries.

6. Select the File > Print menu command.
The "Print" dialog box with the activated standard printer opens
(local printer, network printer).

7. Click the "Print" button.
Depending on the print range that has been defined, the complete
program, a certain number of lines of the program or a selected
range of the program is printed.

4.3.7 Starting and shutting down a machine.

Precondition

● Machine configurations are available in the machine overview.

● You need a license to be able to use the entire range of functions. Information on
function restrictions can be found under License model (Page 55).

Starting a machine

The machine overview is open.

1. Select the required machine in the list of machine configurations.

2. Select the Machine > Start menu command.
- OR -
Right-click and select "Start" from the context menu.
- OR -
Click in the machine configuration.
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The machine simulation opens with operator panel and SINUMERIK Operate
user interface, machine control panel with feedrate and spindle override and CNC
keyboard.

3. You operate SINUMERIK Operate using a mouse or a standard keyboard.

4. When operating SINUMERIK Operate, click the <HELP> key or press key <F12>
to obtain context-sensitive online help for the window and the input screens of
SINUMERIK Operate.

Shutting down the machine

● Select the Machine > Shut down menu command, if you wish to exit the actual
machine configuration.
You return to the machine overview.

Restarting the machine

● Select the Machine > Restart menu command, if you wish to restart the actual
machine configuration - for instance, after changing machine data.
The machine shuts down and is then immediately run up again.

4.4 Problem handling

4.4.1 Creating a trace
Should problems occur while working with SinuTrain, you have the capability of
creating a trace.

To do so, activate the tool "SinuTrain for SINUMERIK Operate Trace". The tool then
logs all of the actions and events of the next SinuTrain session in a text file, which
you then send to the hotline for analysis.
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General conditions

The trace tool can only be activated or deactivated when SinuTrain is not running.

Procedure

1. Ensure that SinuTrain is not running.

2. Navigate to the installation directory (default path: "C:\Programs
(x86)\SIEMENS\SinuTrain") and open the "SinuTrain Workbench" folder.

3. Double-click the file "sinutraintrace.exe".
The tool "SinuTrain for SINUMERIK Operate Trace" is opened.
"Storage path" shows the path to the folder in which the trace file is saved.

Note
Changing the save location
Click on the "..." button and navigate to the desired save location. Click on the
"Create new folder" button, assign a name, and click on the "OK" button.
The selected storage path is saved.

4. Click the "Activate" button.

5. Start SinuTrain and reproduce the steps that led to the problem.

6. Switch to the trace tool and click on the open "Trace folder" button.

7. Copy the file "sitrace.txt" that was saved in the folder and send it via e-mail to
Technical Support (Page 48) for analysis.

8. If you want to deactivate the trace tool, you must first close SinuTrain beforehand.

Note
Information on system data
With the aid of the "Display system data" button, you have the capability of displaying
information about the operating system, the processors, and the current memory
allocation. Using the "Copy system data to the clipboard" button, save this data to the
clipboard for forwarding to the hotline.
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5 Additional documentation

5.1 Operating Manual and training instructions
When using SinuTrain, you have the option of using the context-sensitive online help
of SINUMERIK Operate via the HELP key.

Furthermore, additional and more in depth operating manuals and training
documents are available in six languages (German, English, French, Italian, Spanish,
simplified Chinese).

Note
If a particular foreign language version of a document is not available, then as an
alternative, the English edition is available.

Operating Manuals and Training Documents

● Easy milling with ShopMill
– Milling basics
– Handling the program
– Step-by-step instructions for programming and machining various examples

● Turning made easy with ShopTurn
– Turning basics
– Handling the program
– Step-by-step instructions for programming and machining various examples

● Milling
– Detailed operating manual for SINUMERIK Operate on SINUMERIK 840D

sl/828D, milling version.

● Turning
– Detailed operating manual for SINUMERIK Operate on SINUMERIK 840D

sl/828D, turning version.

● Universal
– Detailed Operating Manual for SINUMERIK Operate on SINUMERIK 840D sl,

Universal version (without cycles description).

● Basic Functions
– Detailed Function Manual with a description of basic SINUMERIK functions.
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● Programming Manual, Fundamentals
– Programming Manual for users with a basic knowledge about drilling, milling

and turning.
– Simple programming examples that also explain commands and operations

according to DIN 66025.

● Programming Manual Advanced
– Detailed Programming Manual with a description of all parameters.

● Function Manual ISO Dialects
– Description for the commissioning and execution option of part programs

belonging to external CNC systems.

● Programming Manual, ISO milling
– Detailed description of the special issues when programming in the ISO

mode, milling version.
Programming Manual, ISO turning
– Detailed description of the special features when programming in the ISO

mode, turning version.
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A Appendix

A.1 Menu commands
The following menu commands are available to operate SinuTrain:

Menu Menu commands Function
File New From a template... Changes to the "Create new machine -

Use template" window to create a new
machine.

From a setup
archive...

Changes to the "Create new machine -
Read setup archive" window to create a
new machine.

Copying and inserting Copies the machine selected in the
machine overview and inserts it in the
list of machines.
You then change the properties of the
copied machine via the Machine >
Settings... menu command or the
"Settings..." command in the shortcut
menu.

Delete Deletes the selected SinuTrain
machine.

Import... Changes to the "Create new machine -
Import machine" window to transfer
stored and saved machines to the
machine overview.

Export... Opens the "Save as" dialog to store and
save machine configurations from the
machine overview.
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Menu Menu commands Function
Print settings... Switches to the "Print settings" window.

Here you define the margins and print
range and select the representation
type of the NC programs for printing.

Print... Prints programs corresponding to what
has been defined in "Print settings" from
the SINUMERIK Operate editor.
Note:
Only active for started machines.

Exit Exits SinuTrain for SINUMERIK
Operate.

Machine Start Starts the machine configuration
selected in the machine overview.

Restart Shuts down the SinuTrain machine and
then restarts it automatically.

Shut down Shuts down the SinuTrain machine.
The machine overview remains open.

Settings… Changes to the "Edit machine" window
in order to change the machine name,
description, language and machine
image as well as the resolution of the
SINUMERIK Operate user interface.

Extras Install additional HMI
languages...

Changes to the "Install additional HMI
languages" window in order to install
additional available languages for
SINUMERIK Operate.

Options... Changes to the "Options" window to
make the following settings:
· Selection of the language for the

SinuTrain user interface
· Activation or deactivation of

messages in SinuTrain for
SINUMERIK Operate (e.g. message
regarding possible data loss when
deleting a SinuTrain machine)

Help Help on SinuTrain... Opens the online help for SinuTrain for
SINUMERIK Operate.
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Menu Menu commands Function
Help on SINUMERIK CNC-
SW

Opens the online help for release-
specific information.
The submenus depend on the installed
CNC software versions.

Info... Changes to the "About SinuTrain for
SINUMERIK Operate" window to obtain
the following information:
· Product version of the installed

SinuTrain for SINUMERIK Operate
· Data of the versions of all CNC

software packages in the "Installed
SINUMERIK CNC SW packages"
area
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A.2 Context menu
There is a context menu with the following commands for each machine page in the
machine overview:
Menu commands Function
Start Starts the machine configuration selected in the machine

overview.
Export... Opens the "Save as" dialog to export machine

configurations from the machine overview.
Copying and inserting Copies the machine selected in the machine overview and

inserts it in the list of machines.
You then change the properties of the copied machine via
the Machine > Settings... menu command or the
"Settings..." command in the context menu.

Delete Deletes the selected SinuTrain machine.
Settings… Changes to the "Edit machine" window in order to change

the machine name, description, language and machine
image as well as the resolution of the SINUMERIK
Operate user interface.
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A.3 Operation with standard PC keyboard
The following keys and key combinations are available for operation of SinuTrain
SINUMERIK Operate.
PC keyboard Function
<F1> ... <F8> Horizontal softkeys 1 to 8
Shift + <F1> ... <F8> Vertical softkeys 1 to 8
<F9>

Shift + <F9>

<F10>

Shift + <F10>

<F11>

<F12>

<Page↑>

<Page↓>

<Enter>
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PC keyboard Function
<Insert>

Numerical block <5>

<Esc>

<Ctrl> + <Alt> + <Shift> + <1>

<Ctrl> + <Alt> + <Shift> + <2> The operational SinuTrain machine is run down.
<Ctrl> + <Alt> + <Shift> + <3>

<Ctrl> + <Alt> + <Shift> + <4>

<Ctrl> + <Alt> + <Shift> + <5>

<Ctrl> + <Alt> + <Shift> + <6>

<Ctrl> + <Alt> + <Shift> + <7>

<Ctrl> + <Alt> + <Shift> + <8>
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